Paint Shop Pro 7 skinning tutorial – Part III.

By John “Chompy” Masters.

This tutorial is designed to show you how to make an aircraft skin for “European Air War” (, using Paint Shop Pro 7 (. While the instructions are specifically for PSP7, the general concept can be used for other versions of PSP, and any decent graphics program that utilises layers, such as Photoshop etc.  Also most of the skinning detail will work for most other flight-sims with a few adaptations- the main difference with other sims is that you don’t have to worry about palettes and colours as much as with EAW.  The settings mentioned are guides only, so feel free to alter them as you see fit.  Please note that while these are the techniques that I am currently using, they are not the only way to do it, and may not even be the best way to do it, but they work quite well and give good results.  While this particular example outlines how to make a layered template for a High-res EAW aircraft skin, the same painting methods can be used for all skinning.  

If you are completely new to working with layers and PSP, it may pay to have a look at my original ‘Layers Tutorial’, parts 1 and 2 (Links at the bottom of the page).  They provide a good introduction to the concept of layers, but do some extra stuff which I do not use as much now – in particular the Adjustment Layers.  While the description and implementation of them is correct, I’ve found that for panel lines, rivets, shading and highlights, it is a lot more user friendly to use Raster layers instead.  Other than that, Parts 1 and 2 should give you some good information.  Part 3 is simply an update, with some new techniques and ‘refresher’ courses.

Remember that there is no right or wrong way to produce a skin, but you will find that there are methods that can save you time, and possibly give you a better finish, and that is all we are aiming to achieve.  With time and practice, you will develop your own individual skinning style using whatever methods you think work best for yourself.  Good luck! 

Extras.

Included in the .zip is PSPshortcuts.jpg - This lists the keyboard shortcuts for all the commonly used Tools, Operations, and Windows, and you might find it quite handy.  Open this up in PSP and print a copy for future reference. 

The layered templates for the B-17 can be downloaded from Sandbagger’s –  in the ADD-ONS page from the link below.  These include the  Fuselage template.PSP, Pbb17lex.PSP (wings), and Pbb17N.PSP (nose-art), plus another nose art file, and some .SEL selection files.  Note that the B17LEX file has several Adjustment layers in it.  This was done a year ago when I was still using a lot of Adjustment layers.  I have since found that Raster layers are much easier to work with when making panel lines, rivets etc, but this template still works fine.

The base .tpc files, batchfiles for the B-17 can be downloaded from any of the B-17’s at my site at Sandbagger’s - http://www.sandbaggereaw.com/chompy.html
The Concept.

What we want to do is create a multi-layered image, where every separate bit of detail is contained in its own layer, where it can be individually adjusted without affecting the rest of the image – kind of like painting on several sheets of clear plastic.  The basic paint colours and markings will be towards the bottom of the layer stack, with all the markings, panel detail, shading, rivets, highlights etc. above it.  This way if we can completely change the look of our image, with a minimum of effort.  Whenever we do any work on our images, we want to do it in 24 bit colour so that we can use all of PSP’s tools and FX, as the 256 colour EAW palette will not allow the use of all the tools.

If all you’re previous skinning has been done on one layer, don’t be put off.  Using multiple layers is just as easy as using one layer, but gives you a huge amount of extra possibilities.  Here’s an excellent piccy that DeanH made, which helps to illustrate the concept of using layers.
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When you combine all those layers together looking from the top, it looks like this –
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This is an excellent looking side profile, done with only five layers.  I prefer to use a few more layers, so I will outline the steps I have gone through to make my B-17 fuselage template.  Have a look at this file, and it may help you to see what we are trying to achieve.

What you will need.

- Paint Shop Pro 7 ™ or any quality graphics program.  Download the PSP 8 trial version from http://www.jasc.com/
- The PCX files for the aircraft you wish to skin.

** Note that PSP8 and 9 have some different layouts to the PSP7 ones used in this tutorial.  All of the tools and effects mentioned are still there, it’s just that some have been relocated or re-badged.  For example Colours>Load palette in PSP7 is found under Image>Palette>Load palette in PSP8, and Effects>Noise>Add is found under Adjust>Add/Remove noise>Add noise, the Lines tool is now the Pen tool etc.etc.  **

Research.

Before you begin, you should have a good idea of what the aircraft needs to look like.  Not just the paint scheme, markings and nose-art, but bigger picture of lighting/shading FX, panel line layout, weathering and staining.  Get hold of some good reference pictures, and have a look at some other people’s skins (not just EAW either!) to try to identify what aspects of their skins you really like, as well as anything you dislike.  There is no shame in using other people’s great ideas on your own work, particularly if you are going to execute the ideas yourself.  The challenge is to work out how to get that look on your skin, but with practice you will soon get a good idea of which tools and FX you should be using. 

Another nice touch is to find out the history of the aircraft, and include those details in the readme.txt file.  With a little searching on the net, you should be able to find it’s squadron, group, base, pilot and maybe some memorable missions it participated in.  All these little things help tell the story of the skin you are trying to reproduce.

PCX and TPC.  

The EAW graphics engine uses .TPC files for all its textures.  These are just .PCX files that have been compressed using the PICPAC utility.  Now, to do any skinning we need to work with the .PCX files, and sometimes they are included in the downloaded zip, but most often these days they aren’t – purely to reduce the size of the download.  The easy way to convert the .tpc’s to .pcx is with the GpmTPC2PCX.exe utility and a batchfile.  

Batchfiles

These are very useful, not just for the ‘reverse Picpac’ operation to convert TPC to PCX.  With todays HR aircraft using many PCX files, life can be made easier with the use of batchfiles.  They allow you to Picpac or ‘reverse picap’ all the files in your folder with a simple double click.  Sometimes these are available for download, but if not, they are very easy to make.

A batchfile is merely a simple renamed text document which gives the computer instructions on what it should do.  Here’s how to make one to reverse picpac the B-17.  Create a new text document, and name it HRB17TPC-PCX.txt  .  Now open it up and type in –

gpmTpc2Pcx.exe PBB17TEX.TPC PBB17TEX.PCX

gpmTpc2Pcx.exe is the program used to do the converting,

Pbb17TEX.TPC  is the name of the file we wish to open up and convert,

Pbb17TEX.PCX  is what we want the converted file to be saved as.

** Note that there is a single space between each of these three elements. **

That is one command, now type in the rest, with each on its own line, so that you have written down a command for each .tpc file you have that needs converting.  It would look like this –

gpmTpc2Pcx.exe Pbb17n.TPC pbb17n.PCX 

gpmTpc2Pcx.exe Pbb17tex.TPC pbb17tex.PCX

gpmTpc2Pcx.exe Pbb17lex.TPC pbb17lex.PCX

gpmTpc2Pcx.exe Pbb17rex.TPC pbb17rex.PCX

gpmTpc2Pcx.exe Pbb17bex.TPC pbb17bex.PCX

gpmTpc2Pcx.exe Pbb17tra.TPC pbb17tra.PCX

gpmTpc2Pcx.exe Pbb17mex.TPC pbb17mex.PCX

Now save the file, and rename the extention from .TXT to .BAT – that’s it!!  If you ever need to alter your batchfile, just change the extention back to .TXT and you can open it with Notepad again.

A batchfile to picpac a file would have a command line like this –

Picpac.exe –p Pbb17tex.pcx Pbb17tex.tpc

The –p designates that picpac will save the palette during compression.  Note that the file we are opening is .pcx , and the file we are saving as is .tpc .  This is the exact same command that you would type if you were using picpac through an MSDOS prompt.

When you run the batchfile, it looks (in it’s folder) for the necessary .exe and files specified in the command line, so all the files you want to convert, plus the necessary .exe, must be in the same folder as the batchfile.  If the batchfile can’t find the file it is told to open, it just skips it and goes on with the next one.

If you’re not comfortable with batchfiles or DOS prompts, and only want to use picpac, then make sure you get the Picpac GUI program available at Mosi’s site - http://mosi.furballcentral.com/  As well as picpacing single files, it can be set up to process batches of files as well, but only PCX to TPC.  To go from TPC to PCX a batchfile is the way to go.

Some Organization.

Create a skinning folder that is easily accessible.  In this folder you need to put-

· the Picpac.exe

· the gpmTpc2Pcx.exe

· your batchfiles.

· The PCX or TPC files you wish to start with.

Also create some other sub-folders for Screenshots, 3dz’s, reference pictures etc. 

If you don’t have the PCX files yet, double click on the TPC-PCX batchfile, and they will be converted in a flash for you.  Beware that the batchfiles will overwrite any existing files with the same name.

Setting up.

First make sure that you have the necessary PSP features enabled.  Click View>Toolbars, and ensure that you have ticks next to the Standard Toolbar, Tool Palette, Colour Palette, Status Bar, Tool Options Palette and Layer Palette, as well as the Automatic Rollups box, then click OK.

Creating the fuselage template.
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This example uses the Fuselage for a High-res B-17 F.  As with most High-res aircraft, the PCX file is split halfway along the fuselage (if your fuselage isn’t split into two PCX’s, you can skip this bit).  We want to skin the entire fuselage in one piece, because if you skin it in two separate halves, it can be very difficult to get your panel lines/shading/highlights etc to line up when the two are joined together.  In order to get a perfect seamless join in game, we need to skin the fuselage as one, and then paste the various halves back into their PCX’s.  To make the halves line up perfectly every time we paste them in, we will make some ‘corner markers’ which will assist with the alignment. 

Open up the Pbb17TEX.PCX and take a look in the bottom right corner.  The series of Black and Yellow pixels designate where the corner of the right front fuselage file must go. (picture below)
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If you look above that, you can see another set of corner markers for the left side of the front fuselage.  Note that the both sets of markers are in the same spot when compared to the rest of their fuselage side.  Now open up the Pbb17BEX.PCX and check for corner markers.  This time they are both in the corners of the image, which makes it easy (If you don’t have corner markers on your PCX file, just paint some into a suitable corner.).  The corner makers provide a concrete reference point for pasting in the rest of the skin.

On the TEX, use the Freehand selection tool [image: image3.jpg]


 to select one of the front fuselage halves (In the Tool options box, set the selection type to suit – freehand or point to point work fine, with Antialias Unchecked, Feather 0, and Sample merged Unchecked.)  Once you have this done, also select the Corner marker that goes with it (Remember, hold down SHIFT to add to your current selection, and CTRL to delete from your current selection.).  When you have this done, Copy (Ctrl. C) it to the clipboard.  Create a new image, 600x300 pixels, 24 bit colour, with a transparent background, and Paste as a new Selection (Ctrl. E) the front half of the fuselage into the image.  While you have it, hit Selection>Save to disk, naming it suitably, as this selection will come in very handy later on.

Repeat the same procedure on the BEX, selecting the rear fuselage half AND it’s corner markers, and copy and paste it into the new template.  Take EXTREME CARE getting the two halves to line up perfectly as you paste it in.  Save the selection, and save your file, making sure that it is in the Paint Shop Pro .PSP format which supports layers.  Make sure that you save your work from time to time as you develop the rest of the template.  Now you have a one piece background, which will provide a base for the rest of your template, and you are ready to start skinning!
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Skinning with a ‘one piece’ PCX file?

If so, just take your starting PCX, go to 24 bit colour by hitting Colours>Increase colour depth>24 bit, click File>Save as, and save it in the Paint Shop Pro .PSP format, which supports layers, and remember to save your work from time to time as your template evolves.

Optional Resizing.

An option you may want to try is to double the size of your canvas.  Some skin artists like to work on double sized canvases, which can be helpful for several reasons.  Basically you do all your skinning as normal, but because of the extra resolution you can add a lot of extra detail.  When you have the finished product, you resize by 50% to get back to your starting size.  This downsizing retains a lot of the detail originally drawn in, but it does depend on the content.  A 1 pixel line drawn in a 512x512 image may not show terribly well when you resize it back to 256x256, but a 2 pixel line will show nicely, so if you double the size of your starting image, experiment to see how much of your line/rivet details will be retained when shrunk.

Another possible bonus is the fact that a double sized skin will be perfect if you are ever able to use 512x512 skins for EAW.  One of EAW’s resident skin-gods, Jeff “Salty” Salter has always done his skinning at twice the required resolution, and when I found that I could run at 512x512, all the skins he had done worked perfectly with amazing resolution.  Just something to think about, as you never know what the future may hold!

Aside from the file being four times as big and slow, the main drawback with double sizing is that you can draw in an amazing amount of detail thinking that you are doing a great job, but when you shrink it to normal size you may lose a lot of your work.  Any ‘dithered’ backgrounds you use will be blended, and any ‘Noise’ effect may be lost, as basically the resizing operation combines four pixels into one.  Compare that to working on a normal sized image, where what you see is more or less what you will end up with. 

The choice is yours – if you want a double sized canvas, do it now, by clicking Image>Resize, set to Percentage of original, and 200x200, with Resize type as Smart size, Resize all layers checked, and Maintain aspect ratio checked.

**  Note that the brush sizes I suggest from now on, are to suit a normal sized image. **  

The Base Paint Layers.

The first thing we will do is create a basic paint layer, which allows us to see all our work a little clearer.     You may remember from previous tutorials, that it helps to get the colour you will be using from a PCX file.  If you take a colour from PSP’s 24 bit palette, it may look a completely different colour when you convert it to the EAW palette, so I find that it’s best if you take your colours from the EAW palette you intend to use, as you know you will get a close match with the finished product, and also you know how many lighter and darker shades you have of that colour, which is useful when adding light and shade FX.  If you decide to use a colour that isn’t well represented in the EAW palette, then you will have problems later on, so you may just have to accept that the perfect colour cannot be used.  I’d recommend that you use the default EAW palette for the aircraft slot that you are skinning, to avoid any compatibility issues.  Open a PCX file that contains the palette you wish to use, and hit Colours>Save Palette, and enter a name so that you can easily load this palette later on.  Leave the .pcx file open, so you can select colours from it’s palette later on.

 Go back to your template and use the Magic Wand [image: image5.jpg]


 (Match mode RGB, Tolerance 0, Feather 0, sample merged unchecked) to select the area outside of the fuselage, then click Selections>Invert, and Save the Selection to disk (If you have a ‘one piece’ template, you may have to use the Freehand selection tool [image: image6.jpg]


 instead of the magic wand – we only want to select the fuselage).  Open one of your PCX files and take a basic grey from the EAW palette (RGB 156,158,159), switch back to your template.  Now create a new raster layer by clicking Layers>New Raster layer, and call it “ Metal base” (Another way to create a new layer is to open the Layers Palette and right click a current layer that you want the new layer to appear on top of, then select New Raster layer. Remember that every time we create a new layer, it appears directly on top of the layer we are currently viewing.) Use the Floodfill tool [image: image7.jpg]


 (blend mode – normal, Match mode – RGB, Tolerance –200, Opacity – 100, Sample merged unchecked) to fill the selection with paint.

Using the same procedure, create a new “Green base” layer and fill it with a medium green (RGB 72,82,39).  If you need to change the colours, you can easily come back and floodfill them with another colour.

If you have any other painted panels, or camouflage markings, do them on a separate layer above the base paint layers, but it may pay to come back and do them a bit later when you have some panel detail drawn in to help guide you.  If you are painting a camouflage scheme, use the Airbrush [image: image8.jpg]


, as it gives a nice softened edge to the paint.  A typical setting for brushing on camouflage would be Shape – round, Size 20, Hardness 45, Opacity 100, Step 25, Density 100.  You will find that if you use a large Airbrush to do some of the work, and then use a smaller airbrush, it’s edge will be a lot harder than the big brush.  To match them up, use the Retouch tool [image: image9.jpg]


 set to Soften, Shape – round, size 10, Hardness 50, Opacity 30, Step 25, Density 100, and soften up the harder edge.

Airbrushing, and brush settings.
The Airbrush is one of the most useful tools for skinning, so take some time to get used to it’s settings, and how to get the most out of them - the key here is to experiment!  Almost all tools have a brush settings box, and with each tool the settings do the same thing.  Here’s a quick run-down of each setting -

Shape – Easy to work out!  Most of the time just leave this as round.

Size – in pixels (
Hardness – Controls how well defined the edge of your brush is.  100% leaves a hard edged outline, 0% is soft.  Anything from 0 to 50 is ok for most airbrushing.

Opacity – Controls how much paint is deposited with each stroke, from 100% giving a solid colour, to 1% which only puts down a faint touch of colour.

Step – How many times the brush touches the canvas as a percentage of the brush width while stroking the brush.  For example, at step 50%, as the brush moves, it will touch the canvas twice for every width of the brush.  Most of the time just leave this at 20 or 25. 

Density – the percentage of the brush’s surface that leaves paint on the canvas.  From 0% (hardly any) to 100% = full cover.

The following comparison shows the changes you get if you alter one of the brush settings (without changing any of the other settings).  All strokes are set at size 25 and Round.
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By altering and combining all the values, you can get an almost unlimited variety of brush tips.

Dithered Backgrounds.

One technique I’ve been experimenting with is using a ‘dithered’ background colour.  For example, the EAW palette has a reasonable range of greens and a good range of browns, but there are no ‘greeny/browns’ and so it is hard to get a nice faded olive drab look – if you have a nice olive drab colour in 24 bit, when you load the EAW palette it will either turn to green or brown, depending on which of the two colours it is closest to.

  However if we make a background composed of alternating green and brown pixels, we can fool the eye into thinking that we have a nice olive drab colour, and fool the EAW palette too!  This can work nicely, but has it’s limitations.  From a distance it looks great, but closer up you can see the individual pixels, plus you also get the ‘Moiré’ effect at certain angles, where the pattern forms lines of each individual colour you have used.  The way to break the Moiré effect is to use a random pattern of the pixels, rather than a repetitive pattern.  Unfortunately a more random pattern takes the smoothness out of your perceived colour and adds a pixelated blockiness, and while it does reduce the Moiré effect, it will not eliminate it completely, so once again you have a trade off, so experiment and let your eye be the judge!

To give you an idea, here are some shots of different base layers (with other layers drawn on top).  From the left, a straight brown base (RGB 119, 97, 76), a straight green base (72, 82, 39), and a ‘dithered’ base using the same brown and green in an alternating pattern.
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When you get close up you can see the exact nature of the dithering, but from a distance it blends in well.  Hard to believe that the same green and brown are used when you get up close, isn’t it!!  Be warned that dithered backgrounds will not look as good on low-res skins.

To make a dithered background, take the colours you need from the EAW palette, and start making the alternating pattern on a new layer.  Use a 1 pixel brush to do a 6x6 pixel block, then select, copy (Ctrl C), and paste (Ctrl E) it 8 times around your first block, making sure the pattern is continuous.  From there select the 18x18 pixel block, copy and paste etc.  Keep getting bigger until you have a big enough chunk to paste conveniently.  When you have all of the fuselage pasted in, to keep things tidy hit Selection>Load Selection from disk, and load the entire fuselage selection that you saved earlier.  From there hit Selections>Invert, and hit the delete key to remove the excess paint, and then Invert the selection again so that you are ready to work on the fuselage again. 

Adding Noise.

This helps to take the plain, boring look out of your base skin, and gives it a bit of character.  There are a couple ways to use this effect.

1. Put the Noise effect on every one of your painted surfaces.

2. When merging your final image into one layer, add the noise to everything then.

Choose whatever suits you best – you might not even like the noise effect.  To use it, just make sure you have the correct layer activated, and select the area you wish to add noise to (usually all of it), then click Effects> Noise>Add, in a Uniform pattern, and add about 4% noise, depending on your taste.  Remember the Undo button [image: image12.jpg]


 is your best friend if you get an effect you want to change.  Here’s a pic of before, and after 4% noise was added.
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If you ever want to test your template in game, you can fast forward at any time to the “Converting to the EAW Palette” section and follow from there.

Panel lines.

These give a lot of detail to a skin, so it’s important to get them right, and structured so that you can easily alter the bits that you want.  Everyone has their own preference to how the lines should look, so feel free to experiment.  You may want to create several different layers for the panel line detail – one for average panel lines, one for softer lines, and one for darker lines (ailerons/rudder), as this way they can all be altered independently.  Here’s an example showing four different types of panel lines.
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Raster or Adjustment??

In previous tutorials I’ve used Adjustment Layers to do the panel lines and shading, but at the moment I’m more inclined to use Raster layers instead.  Why?  I’m glad you asked!  Raster layers are much simpler to work with, for the fact that you can select, copy, paste and move bits around easily, while Adjustment layers can’t be copied, pasted or selected and moved (although you can move the entire layer, or use the Clone brush to move bits).  

The one area that Adjustment lines beat Raster lines hands down, is on backgrounds with very different brightnesses, such as the invasion stripes.  The wing above has all it’s lines done on Adjustment layers, and you can see that the light/dark lines are equally well defined across the bare metal, white, and black paint.  This is the kind of effect we are after, and while it can be done well with Raster layers, it will never look quite as good.  Let’s compare the two together.

[image: image15.jpg]Raster
Adjustment

Dodge / Burn|




Here I have a plain metal background with contrasting invasion stripes.  The top lines are done with Raster layers, the Middle line is done with Adjustment Layers, and the Bottom line is done with Raster layers with the blend modes set to Dodge and Burn.

On the far left you can see that all the panel lines start off the same colour.  Lets take a close look at the Raster lines first – as they move into the white paint, you can see that the light line is poorly defined, and the dark line becomes prominent.  As it gets into the Black paint, the light line becomes very well defined, and the dark line gets very hard to see.  Because our Dark raster lines are just adding more black, the closer the background gets to black, the less of the effect you are going to see, and vice versa for the brighter areas.  Not what you would call a nice, even effect, although it’s not bad.

Looking at the Adjustment lines now, you can see that both lines retain their relative intensities across all three colours.  Because we are Adjusting our background X% darker/ lighter, the effect stays consistent and uniform (until the background is totally black or white, and then there is no room for adjustment – this is why you should never use pure white or pure black as your backgrounds).

The Dodge/burn lines are similar to the raster lines, except in reverse.  The Burn (darken) works strongest on dark backgrounds, and the Dodge (lighten) works strongest on light backgrounds.  Dodge and Burn work best on colours.

Here you can see that if you have a background of varied brightness, your panel lines and rivets will look best on Adjustment Layers.  If the brightness doesn’t vary too much you can probably use Raster lines quite successfully.  If you want to use Adjustment Layers for your lines, you can either follow the instructions outlined in my “Layer Skinning Tutorial part 2” to create the layer, or change a Raster lines layer into an Adjustment layer later on.

If you just want to use Raster layers for your lines, read on!

Raster Lines

 Create a new Raster Layer on top of the Base paint, and call it Dark lines.  Now in the Layers Palette, switch off the Green base’s visibility by clicking the glasses icon [image: image16.jpg]


 so it changes to have a cross through it [image: image17.jpg]


, and dial the Metal base layer’s opacity slider [image: image18.jpg]- Base Metal Ha |HEER D | Nomal



back to 60% or so, until you can see the background’s panel line detail showing through.  You have the choice of using the existing panel lines as a guide, or making your own lines wherever you want.

Set Black 0,0,0 as you foreground colour, and use the Draw tool [image: image19.jpg]


 (Type – single line, Width  1, Line style – solid, with Antialias, Create as vector and Close path all UNCHECKED) to make your lines.  Don’t worry if your lines look too dark, as we will tone them down in a minute.  Do all the vertical and horizontal lines first, then CHECK the Antialias box, and draw the diagonal lines.   With the AA checked, it draws softer, wider lines, and depending on your taste, you may want to use it with your vertical and horizontal lines.  Here’s a pic part way through the process.
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With your main panel lines layer done, adjust the layer’s visibility slider until you get a blend that you think looks right.

If doing a ‘Minor panel lines’ layer, do it now in much the same way, except use AA on all the lines, so that they blend in nice and smoothly.

The ‘Really Dark lines’ may be able to be done on the Dark lines layer, by adjusting your line width to 2 pixels, but if you want them 1 pixel wide and darker, you will need individual adjustment for it, so do them on another layer.  In the B17 example, the dark line for the rudder needs to be more than one pixel thick, and also needs to gradually fade away, so here’s the technique for doing that.  Make your new layer, Set the line width to 2 or 3, and draw the line with one edge exactly where you want it.  Now switch to the Retouch tool [image: image21.jpg]


 and set it to Soften, Shape – round, size 6, hardness 51, opacity 50, step 25, density 100, and brush the edge of the line you want to fade out.  Remember that if you left click, hold shift, move your brush and click again, PSP will automatically draw a straight line between the two points.  Make a few passes like this until you have the edge softened nicely.  Now you can use the selection tool [image: image22.jpg]


 and Delete key to select and cut any overspray you may have had with your original line.  From there, just adjust your opacity.  Here’s a picture showing this operation in various steps.
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If you ever have any curved lines to be drawn, set the Type to “point to point”, make sure AA is checked, and set your background colour to Null, by left clicking the black arrow on it’s colour box, and selecting the Null icon (picture) [image: image62.jpg]


.  Now you just click wherever you want the line to go.  If you find that the curve is not quite right, you can drag and drop each node to another location with the mouse.  When you have all the nodes where you want them, press Ctrl Q to draw the line.  When done, don’t forget to enable the background colour again - by selecting the ‘brush’ icon this time.

Converting Raster lines layers to Adjustment lines - Optional

Activate your Dark Raster lines layer, select the Magic wand [image: image24.jpg]


 tool and set it’s options to Match mode – RGB, Tolerance – 0, Feather – 0, sample merged UNCHECKED.  Click somewhere outside your lines and then hit Selections > Modify > Select Similar, and then Selections > Invert.  Now click Selections > Float (CTRL F) , then Colours > Negative image, then Layers > New Adjustment Layer > Brightness/Contrast, name it suitably and shift the brightness slider to –50.  On the layer palette activate the ‘floating selection’, hit the delete key and then CTRL D to defloat, then switch off your Raster Lines layer and adjust the opacity of the new layer to suit.

Light lines – 3D

Now it’s time for a nifty trick I learned form DeanH – Cool!!  Once you have your Dark Lines Raster layer finished, on the Layers palette, right click the layer and then Duplicate, and right click that layer and rename it to Light lines.  Now from the toolbar click Colours>Negative image.   Click Selections>Select all (or Ctrl A), and use one of the Selection tools to pick up and shift the entire light lines layer 1 pixel to the right, and one pixel down.  When it’s in the right spot hit Ctrl D to deselect/defloat the selection.

** NOTE – for PSP8/9 users, you can record an Autoscript for this procedure, which allows you to automatically add this effect by simply playing a script!  Consult your PSP help file for more details. **

If your lines are on an Adjustment layer use a similar method.   Duplicate the Dark lines Adjustment layer, change it’s Brightness Adjustment to + 75, then use the Mover tool [image: image25.jpg]


 to drag the entire layer across and down 1 pixel.  Remember that the Mover tool will pick up the uppermost layer that it touches, so you may need to shift your adjustment layer up the layer stack depending on where it is buried. Once moved, you can shift it back. 

With the panel lines in place, go to the layers palette and adjust the opacity sliders down until both line layers lines look right.  It is meant to give a 3D depth look to the lines, but don’t overdo it.  Have a think about how the light would play on these surfaces, and try to emulate that effect.   A duplicated light line layer is probably not necessary in minor panel lines and the Rudder join for example.  If there are any parts that don’t need your newly created light lines, just use the Eraser [image: image26.jpg]


 to rub them out, or you can draw in extra ones by using the Lines tool and white as your colour.  This picture shows the new dark and light lines layers showing on top of the base metal layer with the opacity adjusted.
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Rivets.

First create a “Rivets Dark” raster layer.  These are pretty straightforward, but there are several methods which can save you some time.  

1. Use the Brush [image: image28.jpg]


 set to size 1, Hardness 100, Opacity 100, Step 25, Density 100, and black as your colour to paint them in.  However, if you have a lot to do you will then want to use one of the following methods.

2. Create a custom rivet brush.  Paint a row of ten or so rivets and use the square selection tool to select them with the square selection tool.  Switch to the Brush and go to the tool options palette.  Click on the brush Icon and select Custom from the drop down menu.  Click on Create and then OK.  There can be a bit of a bug in PSP7 here, so If your brush tip doesn’t show correctly under the mouse, try again - Click on the brush Icon, Custom, Create and OK again.  Repeat again if necessary – by the third time your custom tip should be ready to go!  Create a few different brushes for vertical and horizontal rivets.  Once you have successfully created a tip, you can easily come back and select it again later.  On the right side of the picture you can see the custom brush in action, painting a neat row of rivets with every click!
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3. Copy and Paste.  Paint ten or so rivets in a line, and select that area with the Selection tool [image: image30.jpg]


, Ctrl C to copy, and then use multiple “Ctrl E to Paste and left click to drop’s – Easy!!

4. Use Custom Lines.  ** MAY NOT WORK WITH PSP8+9 **.  Switch to the Lines tool[image: image31.jpg]


, and in the tool options box set it to Single line, Width 1 pixel, on the drop down box set you line style to #1 Solid, with Antialias UNCHECKED (optional), Create as Vector UNCHECKED, and Close path UNCHECKED.

Now click the CUSTOM line style button and the Styled lines window will appear.  Ensure that all the Caps are set to Flat.  You should see a plain green line in the display window.  OK? now with Add dash set to 1, click the Add button twice, which places a green arrow at the bottom of the style window, indicating the length of the dash, and a red arrow at the top indicating the length of the gap.  Click [image: image63.jpg]o [TCEETTE TS




on the red arrow and drag it to adjust the gap to your preference - about 3 is OK.

You only need one green and one red marker.  Extra repetitions only cause trouble.  IMPORTANT!!

Now click the Save as new button, and give your line a name like Rivets 3 gap.  You may want to make several different line styles with different gaps.

Finally use the Lines tool and black as your colour to draw your lines of rivets, in exactly the same way as we did the panel lines earlier.

Limitations.

-  Angled rows of rivets don't always show evenly.

-  Sometimes you will have a 'double rivet' at an end of the line.

-  The first rivet of a line isn't always at the start of the line, so you may have to start your line a pixel or so left or right of where you want the first rivet.   

Depending on the finish of your aircraft, it may be more effective to use White rivets instead of black.  When you’re done, dial back the layer’s opacity to suit.  If you are using a dithered background colour, you must be careful to place your rivets in the right spot, or they will be negated by the background.

With all the rivets drawn, there are several options to give them a more 3 dimensional look. 

OPTION 1.  Use the Duplicate / Negative / shift trick on the rivets, just as we just did with the panel lines – with one exception.  Instead of shifting the new layer 1 pixel down and 1 pixel right, shift it 1 pixel UP and 1 pixel LEFT.   If the light source is coming from the top left corner of the image, this will give the impression that the panel lines are depressions in the skin, and the individual rivets are raised.  This can work well, but may appear a bit congested, particularly if the rivets are close together. (Another Autoscript??) If the rivets are spaced 3 or more pixels apart and you have high resolution on your skin, you may want to soften them a bit.  On both layers use Effects > Blur > Soften.  This gives the rivets a more rounded appearance (not done in the pic below).
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OPTION 2.  To make the rivets stand out a bit better I like to make a contrasting background for them.  Click Selections>Select all (Ctrl A), in the Layers Palete activate the Rivets Dark layer and Duplicate it by right clicking it’s name and selecting Duplicate.  Rename the duplicate to Rivets Dark backing, and drag it so it is underneath the Rivets Dark layer.   Then hit Colours >Negative image, and soften the line up with Effects>Blur>Gaussian Blur with a radius of 1.0 , and adjust the layer opacity to suit.  Fast, easy, and effective!  You may even want to use this method on the panel lines, instead of the 3d light lines technique mentioned above.  ** NOTE - this procedure would also make a good autoscript. **
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Again, the effects are quite heavy so that you can see them OK, but this is the kind of thing we’re after.

OPTION 3.  If you want to create a 3d depth effect on the rivet lines, we can use the same method as above, and shift all the light backing right and down 1 pixel, but also creating another dark backing layer and shifting it left and up 1 pixel.

To quickly outline this, take the Rivets Dark backing layer you just made above, and duplicate it.  On the duplicate, hit Colours>Negative image, Ctrl A to select all, take one of the selection tools and shift the layer 1 pixel left and 1 pixel up.  Go back to your original Rivets dark backing layer, Ctrl A, and shift that layer 1 pixel right and 1 pixel down, and Ctrl D to deselect.  From there adjust your layer opacities to suit. (Another prospective Autoscript to record.)
Here’s that effect below - once again this is overdone, but you can see how it adds a lot of depth to your rivet lines.  It’s easy to tone down to a level that you think looks best.  This effect probably works best on Metallic looking skins, where these kind of reflections are more likely to occur.  You could also do this effect by hand with the airbrush if you wanted a few lines with this effect, rather than all of them.
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You could even apply option 1 over the top of options 2 or 3.  Of course, if you don’t like any of these rivet backing FX, don’t do them!!

Miscellaneous Bits

Our base skin is coming along fine, but let’s borrow some bits from the background and put them on top of our template.  Activate the Background layer (adjusting the other layers’ visibility so that you can see the background) and use the Selection tools to select all the little bits from the fuselage that you won’t be skinning - things like pilots and windows.  When you have them all selected, copy them, create a new Raster layer called Misc. bits and paste them onto that layer.  Make sure that the Misc bits layer is on top of the deck, so that it shows over the top of all your skinning.  If your aircraft is assymetrical, you may need to create two of these layers – one for the left side, and one for the right.

Grey Bottom.

Most aircraft with green top surfaces were painted with a greyish colour on their bottom surfaces, and now that we have some detail in place we can add this layer more accurately.  Just above your top Base paint layer, create a new Raster layer called Grey Bottom, load up your Fuselage selection from disk, and select a colour from the EAW palette (say RGB 147,149,150), then use the Airbrush set at Shape – Round, Size 16, Hardness 51, Opacity 45, Step 20, Density 100 to brush in the colour.  If you need a hard line instead of a soft line (e.g. under the elevators – pic below), just paint over it, then use the selection tool to define your line, and hit the delete key to cut the unwanted paint from the selected area.   If you have added noise to the rest of your paintjob, you should add noise to this as well, so do it now.
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Contrasts??

Depending on the paint scheme, If you’ve used Raster lines/rivets you may have a severe contrast in your panel lines/rivets when comparing the green top to the grey bottom.  If this is a problem, a solution is to have one set of lines for the green, and another set for the grey.  To do this, Duplicate the lines/rivets layer, then activate the grey bottom layer, using the Magic wand set at Match mode – RGB, Tolerance 0, Feather 0, click outside the grey paint, activate the duplicated lines/rivets layer and hit the Delete key to cut out the unwanted lines/rivets.  Now click Selections>Invert, activate the original lines/rivets layer, and hit Delete.  What you have done is to effectively ‘split’ a layer into two separate layers.

Do this same procedure for any other problem layers.  It can be kind of messy, but can also be very effective.

Another possible fix is to change the Layer Blend Mode to Darken for darklines and Lighten for lightlines.  More on Blend modes after the next chapter – for now, let’s get on with the….

Shading FX

Getting good light FX can really add a lot to your skins.  The general idea is to lighten the top surfaces, and darken the bottom surfaces.  On wings you need to darken the outer edges of the wings, and put a lighter highlight along the length of the wing.  There should be light/shade FX at any spots on the aircraft where there are angle changes.  We need to make a smooth transition of colour from dark to light, so that the shading looks natural and even.  The more different shades of colour we can use in our light FX, the smoother the effect will be.  If this is all done correctly, the skin will have the illusion of being three dimensional.

Here we will do three shading layers.  You may think that it’s a bit of ‘overkill’, but it’s very easy to do everything that you think might need adjusting on it’s own layer.  The first layer (1 in the picture below) will provide the darker effect towards the bottom of the fuselage, trying to emulate the way the fuselage curves away from the light.   Click Selections>Load from disk and load the selection of the entire fuselage that you saved earlier.  Create a new Raster layer called Shading bottom, and dial the opacity slider back to 75%.  Using black as your colour, take the Airbrush tool and set it to Shape – Round, Size 45, Hardness 33, Opacity 1, Step 25, Density 100, and then brush along the entire length of the bottom of the fuselage.  Make multiple passes until you have a nice, smooth transition.  Don’t make the bottom too dark, otherwise the underside of the wings will have to be made the same colour to avoid things standing out. To make the shading more even, it may be worth applying some Effects>Gaussian blur if you want.

That has the bottom of the aircraft looking good, but the Green may not have enough shading on it to change colours towards the bottom.  This can be done on a new layer in much the same way as above, by placing a new layer Above the Green base, but below the Grey bottom. (2 in the picture below)

A third shading layer is used to highlight some of the sharper angle changes in the shape of the fuselage (3 in the picture below).  Create a new Shading Panels raster layer above all the main paint layers, and dial it’s opacity back to 75%.  Load black into your Airbrush (Round, Size 8, Hardness 50, Opacity 1, Step 20, Density 100) and go for it.  Try to visualize the angle changes and how they would look in the sunlight.  Basically you put the shading on the side that would be receive less sunlight, and put a highlight on the opposite side.  Once again, if you need a clean line against a panel, use the selection tools and cut out the area you don’t want (point to point freehand selection with AA works well for angled lines!).

Highlight FX

Once again, I do this with several layers.  First we’ll do the opposite sides of the Shading Panel’s layer we just did – it creates a neat contrasting effect which defines the angle changes a lot better.  Create a Highlight Panels raster layer, dial back to 75% opacity, use White as your colour and the same airbrush settings as above, and the selection tools and Delete key to get any hard edges you need (3 in the picture below).

Now we do the main Highlight layer, which is supposed to give the effect of the sun shining/reflecting off a curved fuselage and top surfaces (4 in the picture below).  Create a new Highlight Main raster layer, dial back to 75% opacity, use white as your colour and the Airbrush with similar settings as you used on the Shading Bottom layer, and give a quick brush around the top surface of the aircraft, but don’t overdo it.  Make sure to do the top surfaces of the tail.

Our fourth and final Highlight layer is for the main reflection (5 in the picture below).  Make your brush a bit smaller and brush a ‘gleaming highlight’ along any surface of the skin which you think would catch the sun.  You can paint freehand, or click your brush, hold down Shift and click again to draw dead straight lines between points (works with any brush tool).

If you ever think you have too many layers, you can merge several layers into one if necessary.  On the layers palette, switch on the layers that you want to merge, and make sure that you have all the other layers switched OFF.  Then hit Layers Merge>Merge Visible.

With the all the layers activated and the layer opacities adjusted to suit, things are really starting to take shape.  Compare Before and after :-
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Alternative ways of achieving Shading and Highlights.

Of course the method outlined above is not the only way.  An easier (but less precise and exacting) way is to use some of PSP’s effects to get the smooth transition you need.  Although this method is somewhat hit and miss, it can be quite useful particularly on wings.

First create a new Raster layer, pick up the Draw tool and set it to Type = Point to Point, Width 5, with AA CHECKED, but Create as vector and Close path UNCHECKED.  Load white as your foreground colour and set your background colour to NULL (See the Raster lines chapter above).  Now paint an outline of where you want the highlight to go.  Do the same for the Shading on the bottom, except use black as your colour.  With that done, hit Effects > Blur > Gaussian Blur, set the radius to 10.00 (or whatever suits),hit OK and adjust the layer opacity to suit.  
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The new shading is smooth and effective, but due to it’s nature can be somewhat unpredictable in it’s results, and hard to control.  Despite it’s shortcomings you may still be able to us it in certain circumstances. 

Layer Blend Modes.

Now that we have a heap of detailed panel lines, rivets, highlights and shading layers all nicely drawn, let’s play around with the Layer Blend Modes to try to get the best out of them.  Go to the Layers Palette and click the drop down box to access all the different blend modes.
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 Experiment with them to see what works best with different layers.  I find that on light layers, Overlay and Dodge seem to bring out the colours the best.  Normal, Lighten, Screen, Hard light and Soft light can also be used, but they tend to wash out the colours a bit.  On dark layers (like dark panel lines), Darken and Burn work well, while on lighter layers Lighten and Dodge work well.  Play around with the blend modes and the opacity sliders until you get a look that you like.

This screenie (taken with some extra layers in place) illustrates the difference that blend modes can make.  All opacity sliders are unchanged, the top profile has all blend modes set at Normal, while the bottom profile has the blend modes pictured above.
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You can see how much extra colour is brought out (It works really well on red backgrounds!)  A lot of this colour will be kept when converting to the EAW palette, but you may want to check to see what is retained.

Insignia.

Now the skin itself is looking quite reasonable, so lets add some national Markings.  These geometric designs are easiest done by using Vector tools, so create new Vector layer [image: image41.jpg]


 directly above the main paint layers, and call it Star and Bar.  Take a dark blue from the EAW palette and put it in both colour pots, pick up the Preset Shapes tool [image: image42.jpg]


, and set it to Elipse, Uncheck retain style, CHECK antaialias, CHECK Create as vector, Line width 1, and Line style Solid.  Place the cursor where you want the circle to begin (remember the co-ordinates in the bottom left corner [image: image43.jpg]


), right click and drag it out until you get the size you want, checking the co-ordinates again to make sure you get the shape even.

Hit CTRL D to deselect the vector, put a light grey in both colour pots, and adjust the Preset shapes tool to “Star 2”, leaving the other settings the same.  Place the cursor at the starting co-ordinates in the middle of the blue circle, right click and drag the star out.

Hit CTRL D, leave the dark blue as your foreground colour, but set the grey as your background colour.  Adjust the preset shapes tool to Rectangle, and right click to drag out the rectangle to the right size.  In the Layers palette, click the expansion tab next to the vector layer, and reorganize the individual vectors so that they display correctly, i.e. rectangle on the bottom, elipse in the middle and star on top.  Remember that you can move any layer up or down the stack by using the ‘drag and drop’ method.
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Your vectors may not be in the exact position you want, so you can adjust them using the Object Selector [image: image45.jpg]


 by clicking the vector to select it and then : -

To move a vector, click and hold on the centre node, then drag and drop.

To stretch a vector, click and hold on the edge nodes, then drag and drop.

To Skew a vector, hold down Shift or Ctrl while dragging an edge node.

To rotate a vector, click and hold on the ‘handle’ coming from the centre node, then drag and drop.

To alter the colours etc. right click the vector and select Properties from the tool options box, and go from there. 

If you right click the vector you are confronted with a whole host of options, so have a read of the PSP manual.

You may need another insignia for the opposite side of the aircraft, if it is assymetrical.  If you have the insignia the way you want it, duplicate the layer and thing hit Layers>Convert to Raster layer.  From here you can select and move it with ease.

Codes and Numbers

Do these on another Vector Layer – ‘Markings’.  Once again, this layer is created just above the main paint layers, but below all the effect layers.  Using the Text tool [image: image46.jpg]


.  Take the colours you need, and set the text tool to Line width 1.  Left click where you want the text to go, and enter it in, making sure that Create as Vector is checked, and also Antialias.  Select a size and font to suit.  A good font to use for squadron codes is Square721 BT, but the choice is yours.  Click OK, and adjust each vector as indicated above.  Make any geometric Group markings with the Preset Shapes tool.[image: image47.jpg]



Once you have all the codes and numbers in place, duplicate the Markings layer and name it Markings LHS, and switch off the visibility on the original markings layer.  Note that all the markings on the LHS of this aircraft must be mirrored so that they display correctly in game.  To do this, use the Object selector to select a vector, and drag one side of the vector over the other side, which effectively mirrors it.  Reposition as necessary, and repeat this procedure with the rest of the vectors.

There are some really great fonts on the web, which are perfect for markings.  Have a look here - http://www.simmerspaintshop.com/colours/fonts.html and download some of them.  Simply extract the *.ttf file into your C/Windows/Fonts  folder, and they will be available for use with your graphics program the next time you restart windows.

Shading on the Codes and numbers.

Usually the shading layers you’ve already done don’t give effective shading for the codes and numbers, and they look the same colour from top to bottom, so we’ll add some shading on another layer, but first we need to get the right selection area.  Start on the Markings layer and use the Object Selector tool, hold down SHIFT and left click to select all of the vectors you want to add shading to.  With that done, right click on the vector and select ‘Create Raster Selection’ from the drop down menu, and create a new Raster Layer and call it ‘Markings shading’.  Because the outside of the vectors are Antialiased, the selection may be a bit too wide, and you may need to hit Selections>Modify>Contract and contract 1 pixel.  Now we can use a black Airbrush to darken the bottom half of each of the markings until we get the right look.  Fiddly I know, but the results make the markings blend in a lot better with the rest of the skin.  Compare the before (bottom) and after shots –
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When you are done, repeat this procedure for the Markings LHS layer.  Also the Insignia might need the same treatment, as has been done in the screenie.

Paint Chips.

Ideally, you would use the Eraser to eat out the paint on the Green Base layer, allowing the Metal base layer to show through it, but it’s generally easier to do it on a separate layer, which allows you to alter the opacity of the chips as needed, and the chips don’t have to be re-erased for every additional base paint layer you do.  Soooo…..  Create a new Raster layer called Paint Chips, making sure that it is above all the paint and markings layers.  Using a light grey for your colour, use the Airbrush set at Shape – Round, Size 2-3, Hardness 45, Opacity 1, Step 20, Density 80, to brush in the effect.  If you like a sharper edge to the paint chips, paint them in with a Brush with Opacity 100 and Size 1, or whatever, but remember that because of to EAW’s lower resolution these may appear a bit chunky.  Keep in mind that wear is most likely on leading edges, walkways, and the front edges and corners of panels.  

As well as paint chips, you probably should do some scuff marks along walk areas.  Do these with a 15-20 pixel brush, and a density of <50.  If you want non mirrored paint chips, create another layer for the other side.

Replaced Panels.

Bombers frequently had panels replaced, and also any fabric covered control surfaces showed a different colour when painted, so here’s how to get that effect.  Just above your Green base layer, create a ‘Replaced panels’ Raster layer.  Take the Freehand Selection tool and set it to Point to Point, Feather 0, and CHECK Antialias.  Now go to a panel that you want replaced and select the outline of that panel.  Replaced panels could be metal or a slightly different shade of green to the rest of the aircraft, so load up the colour you want, and Floodfill the selected area.  You may want to do a few panels with different colours depending on how beaten up your machine is!  If you do several different replaced panels, once again it’s a good idea to do them all on individual layers so that you can turn each one on/off as required.  If you have added Noise to the base paint job, make sure you add noise to the replaced panels as well.

In the same way, do any extra paint layers such as the red tail in the example.

Stains.

These can be tricky to get right!  There are a multitude of stains that can find their way onto an aircraft – mud, dirt, fuel spills, exhaust, gun-smoke, coolant, rust and oil just to mention a few of the more prominent ones.  If you are doing several different stains, you may want them on separate layers.  Anyway, create a new Stains raster layer, dial the opacity back to 75%, and load up a couple usable colours into your colour pots – dark brown and black work quite well, but use whatever colour will suit.  Black won’t be much use for rust or glycol stains!  Use the Airbrush or Brush with whatever size and opacity you need, but set the Density to about 50, and use the left and right buttons to get smears of brown and black (or whatever) in your stain as needed, gently fading the stain out as it streaks rearward.  When you have an effect that looks OK, try this - hit Effects>Blur>Motion Blur, set the desired angle, and use about 2 pixels of shift.  This smears your stain and helps smooth it out.  You may also want to try the Retouch tool set to soften, smudge or push, depending on the look you are trying to achieve.  Experiment with different brush settings until you can get a look that you are happy with.

Shadow.

Of course this is a static shadow which some people may not like, but if you do, here’s how to go about it.  Dial back the opacity on your Green Base layer so that you can see the background image through the rest of the layers as a guide for the elevator location.  Use the Freehand selection tool as you did in the Replaced panels layer to select the area of the shadow, then create a new Shadow raster layer, take black as your colour, set your Floodfill tool to Match mode RGB, Tolerance 200, Opacity 100 and fill the area.  Adjust the layer’s opacity to suit.  Hit Ctrl D to deselect, then use the Retouch [image: image49.jpg]


 tool set to Soften, Shape –Round, Size 9, hardness 50, Opacity 35, Step 25, Density 100, and gradually soften up the bottom edge of the shadow, so that it is much less defined than the top edge.  Towards the bottom, the shadow should blend in smoothly with the fuselage.  You can also try making a shadow effect for under the main wing roots, but this can be tricky.  Often a just a bit of dark airbrushing is generally enough.

Right, that’s got most things under control.  If there are any other details you want to add, now is the time to do them.  Play around with all the layer opacity sliders until you get the effect you are looking for.  If you are unhappy with any layer, you can adjust it, or delete it and start again.

Converting to the EAW palette.

IMPORTANT - Be warned that all the layers will be merged when you apply the 256 colour palette, and you will lose all your layers when doing so.  It is a disaster if you save your lovely template into one layer and lose all the hard work you have done, so be very careful about what you are saving, and make backup copies.  Make it a rule to never hit the [image: image50.jpg]


 icon if you have merged the layers, and always use File>Save as when you are saving your final 256 colour image to a PCX file. 

Now that you have made your basic template SAVE IT!  Save a couple copies in fact!   Be very careful about how you go creating images from your template, trust me - you do not want to learn the hard way……….

You should have a copy of the EAW palette that you wish to use.  I won’t get bogged down in the intricacies of the various palettes, but if you want your aircraft to work on the maximum number of different machines and video cards, I’d suggest that you use the default palette for the slot you are using.  To save the palette, open up a PCX file that has the palette you want, and click Colours>Save palette and enter the details.

Converting from 16 million colours, to a maximum of 256 colours may take a big bite out of your finished skin, depending on the colours you have used in the template.  If you have taken your colours from the EAW palette, and have a few shades each side for the various FX, then hopefully the problems will be minimized.  If you do have problems, hit the Undo button to get back to 24 bit colour and layers.  Now identify which particular layer needs the tweaking and make some adjustments to it’s sliders, and then try again.  You may even have to repaint bits of a particular layer, but that’s always pretty easy – easier than repainting the lot!

One particular colour I’ve had problems with while converting is red.  A lot of the time red that has had highlights applied, won’t convert to the lighter red shades of the EAW palette, but go to a gungy light brown instead.  There are a couple ways to get around this.  First you can try using a different layer blend mode on the highlights.  Instead of using Normal, Hard light or Soft light, try using Overlay or Dodge.  If that doesn’t work, try the method outlined below.

Shift the red paint layer so it is above the highlights, use the magic wand to select just the red area, and then use the Retouch Tool [image: image51.jpg]


 set to Dodge with appropriate brush settings, to apply your highlights directly onto the red layer.  Conversely, set it to Burn to apply shading.  This preserves the colours much better than applying white/black over the top of the red.  If this doesn’t work, you will have to repaint those bits by hand on your finished PCX files.

With everything looking right make sure you save your image now before going any further, then activate all the layers that are needed for the Right side of the template. 

***  If you have made a double sized template, now is the time to resize it back by 50% to it’s original size.***

If you want to add noise, hit Ctrl D to deselect, then Layers>Merge>Merge all (flatten), then Effects>Noise>Add.  If the noise is already in your paintjob you can go straight ahead and hit Colours>Load palette, check the Nearest colour matching option, and select the palette that you saved earlier. 

For comparision, here’s our template in 24 bit colour –
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and here’s what it looks like with the EAW palette loaded –
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As you can see, there are some areas that could do with some tweaking, but on the whole the colours have stayed fairly true to the original, mainly because we used the EAW palette as a colour source.  If you can’t get some spots to give you the exact look you are after, then you can still attack your final PCX’s with a paint brush if need be.

Copying to the PCX’s.

Owing to the fact that there are several images needing to be transferred, this can be a bit tricky.  Seeing we have all the RHS textures activated, we’ll do it first.  Click Selections>Load selection from disk, and load up the front fuselage selection that you saved earlier.  From there, Copy the selection, open up the pbb17TEX.pcx and paste it straight in, making sure the corner markers line up perfectly.

Now go back to the template and load the rear fuselage selection from disk.  Follow the same routine, Copy, open up the pbb17BEX.pcx and paste it in.

Go back to the template and hit the Undo button until you are back with layers, shut down all the RHS layers, and switch on all the LHS layers, and go through the procedure again, copying and pasting in the LHS of the aircraft.  The front fuselage is pretty straightforward, but this time the LHS of the rear fuselage has to be spun around, so when you are doing it just paste it anywhere in the PCX, then click Image>Rotate and check the 180 degrees box, making sure Rotate all layers is UNCHECKED.  From there, use one of the selection tools to move the selection into it’s final place.  With that done, save the PCX files.

Using PICPAC to convert the .PCX files to .TPC

If you made a batchfile to convert the .PCX to .TPC , all you have to do is make sure that you have

1. your new .PCX files

2. the PICPAC.EXE, and

3. your PCX to TPC Batchfile all in the same folder.

Now just double click the batchfile and all the tpc files will be created, ready to copy into your EAW folder and test out in game.

Another alternative to Batchfiles for PICPAC is to use the PicPacGUI_12a.zip .  This is an easy to use windows based utility, which allows you to compress single PCX files, or multiple groups of PCX files.  You can get this at Mosi’s site.

The third option is to open up a MSDOS prompt and run picpac from there, but the first two options are much easier.

Done!

OK, well that’s how to do the fuselage.  The wings need to be done next, and they can be done with a similar method, although most of the time you can just use the wing PCX as the starting canvas for your wing template.  You use the same techniques as we just did with the fuselage, using the same colours for the top and bottom of the wings as you used for the top and bottom of the fuselage.  If your wing template is a ‘one piece PCX’, you can just save it as the wing PCX file, rather than bothering with the copy/paste technique.

The Wing template

This should have many of the same layers that we have just gone through, using pretty much the same methods.  The layer stack should have these kinds of layers.

Misc bits – engine textures, wheels etc.

Stains – perhaps a few stains layers

Dark rivets – dark or light as required

Rivets backing –

Dark shading – just put the shading around the edge of the wing surface on these.

Highlights – put the highlight along the length of the wing, in a spot that would catch sun.

Minor panel lines – optional layer

Heavy Panel lines – dark ones for ailerons etc.

Light panel lines -

Dark panel lines –

De-icing strips –

Paint chips –

Start and bar shading – one layer for each wing

Star and bar – one layer for each wing

Shading for markings –one layer for each wing

Markings – one layer for each wing.

Replaced panels – could be several layers.

Base Paint – several layers, green, camo, metal etc., with different colours for top and bottom surfaces.

Background – starting textures

Other PCX files.

So that has the fuselage and wings made up – great!  However most High resolution models have a few extra files to draw up.  The Cockpit files may need altering, but they are quite easy to do, so I’ll leave them with you for now.  The cockpit Wingview is generally a case of copy/paste from your finished wing files – sometimes a little resizing may be necessary.

The P****MEX.pcx

This file contains the textures for the Medium Distance Model (MDM) and the Long Distance Model (LDM).  In game, when your viewpoint gets to a predetermined distance from the model, the EAW graphics engine uses the MDM instead of the usual Short Distance Model (SDM).  This is done so save on CPU power, so the detailed SDM isn’t drawn at distances where the detail will never be seen, and a simpler MDM or a very simple LDM are drawn instead, improving framerates.  This worked fine with conventional models because the SDM, MDM and LDM all used the same textures.

With HR 3dz’s we are unable to share the same PCX for everything, so the MDM and LDM take their textures from the P****MEX.pcx.  The trick here is to get the MEX using the same colours as your other PCX’s, so that you don’t get ‘flashing’ when your aircraft switches from the SDM to the MDM.  The colours, markings and shading don’t have to be pixel perfect,  the main thing is to get the colour and brightness close.

The easiest way is to find someone else’s work that will match the skin you have made, and use it as your base.  Go through your skin library, and pick out a suitable P****tex.pcx from a low-res skin, or even a p****mex.pcx from a high-res skin (Remember to mention it’s maker in your credits!).  Usually you will have to make some changes.  One way to get colours perfect is to copy them from your new skin, resize and paste them into the MEX.  Some things like the wings can be the right colour, but the wrong brightness.  To fix this, make sure you are in 24 bit colour and select the area that needs adjusting, then hit Colours>Adjust>Brightness/Contrast and alter the brightness value to suit.  A third way is to just roughly draw the areas by hand, using the colours from your other PCX’s.  You can add some markings this way, but don’t get too carried away because most of it will never be seen.

Damage FX.

If you have a really cool HR 3dz, you may even have some extra damage FX that can be utilized.  The most common are the Torn Off Wing .pcx’s , but some like Col. Gibbon’s new hurricane also have these areas on the tail and elevators.  If these are included in your model, here’s how to make some good FX.  Because the file we are working on is not the P****TEX.pcx, we don’t have access to graduated transparency information, but we can still have total transparency, by using the first colour index.

Most TOW pcx’s  have the same layout as the usual wing pcx’s, so you can just take your wing template that you did earlier and add the damage FX to that.

First a little bit on palettes.  The first colour index of the palette has some cool things going for it, but can also cause a [image: image64.jpg]


lot of hassles.  How do you know what the first colour index is?  In the Colour palette that you have loaded, it is always at the top left corner, with the numbers working their way down to the last colour index in the bottom right corner.  In the screenshot (left) I have the Dropper tool over a fluro green bit in the bottom left corner, which displays with it’s RGB content in a box below.  At the bottom of the Colour Palette you see the same RGB info, plus  I = 0.  The I stands for Index, so the colour I have my dropper over is index 0.  ** Note that 0 is the first, and 1 is not 1st!**  Now that you know that, what the hell use is it?

If the Index colour 0 is used in a type 5 element (normal skinned polygon) it will always show up as a black dot, so you want to avoid using this colour in your skins like the plague!

If the index colour 0 is used in a type 6 element (transparency skinned polygon), it will show up as 100% transparent, so it is good for making holes in skins!

So why do I use that poxy green as Index 0 in my skins?  The default palettes usually have a bright white as that colour, and sometimes when you convert from 24 bit to the EAW palette, colour index 0 can be used in parts of the skin.  You probably won’t notice it in your .pcx but it will show up crappy in game.  By using the fluro green (or some standout colour) in this spot, there is next to no likelihood that it will get used in your skin when converting to the EAW palette, and if it does, it will show up like dog’s balls on a cat!  It also works the other way – if my first index colour was close to, or even the same as another colour I had in the palette, when converted to the EAW palette the PCX could be using another colour index instead of the first, so the bits that were supposed to be transparent would show up In colour.  I’ve even seen the pro’s get confused by this!   With a standout colour in index 0, such mistakes can be eliminated.

To change your 1st colour index to a more unmistakable colour, click Colours>Edit Palette, then double click the first colour index and chose something suitable from the colour wheel.  From there save your palette so you can use it later on.  I use this on all skins I do.  The ‘new’ palette will still display exactly the same is it previously did, won’t give any ‘custom palette’ problems (well at least no more than it did before this modification!), because we have only altered the one index which can only ever display as black or transparent, regardless of what colour it is.

Do it!

Ok, on with the job.  There are two ways to make these.  If your starting damaged wing PCX already has some nice damage FX on it, you can easily use these by selecting the damaged areas with the Freehand selector [image: image54.jpg]


 (save the selection to disk for later use), then copy and paste them on top of a copy of your damaged wing PCX file.  It may be necessary to use the Retouch tool [image: image55.jpg]


 set to Soften to blend the edges in a bit better.

If you want to make your own FX, take your finished wing skin template for starters, and add a new Damage FX layer.  First get an idea about how you want the damage to look.  To make bullet holes, first take a light grey and then use the Airbrush set at Round, Size 4, Hardness 45, Opacity 45 Step 20, Density 100, and draw some holes in your wing.  These bits represent the area around the bullet holes where the paint has shattered off the metal.  Naturally, don’t do this if your wings were fabric covered!


Make another layer and take a blackish colour and with a slightly smaller Airbrush and opacity (3 and 3), shade an edge on the inside of the metal where the hole is going to go.   


The last bit is also done on another layer.  Use the 1st colour index as your colour, and paint in the bits you want to be transparent.  This time instead of an airbrush, we will just use the Brush[image: image56.jpg]


 set at Square, size 1, hardness 100, opacity 100, step 25, density 100.  We don’t want the colours to bleed into each other – we must have a defined line between index 0 and the other colours.  If you find that you are running out of room for any ‘holes’, just make the areas on the other two layers a bit bigger.  Another touch is to add fragments of twisted framework and spars through your transparent areas.  Try to visualize what a good damage effect would look like, and try to create it yourself.

When it’s all done, just save your image as the new damaged wing .pcx file.  Here’s an example of a P-47 D damaged wing skin that I did a while back.

[image: image57.jpg]



Transparency files.
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The P****TEX.pcx is the only file that has access to the gradual transparency information contained in the P****TRA.pcx .  If you open up a TRA file, you will see that the palette is chiefly composed of Blue and Pink, with several graduations in between.  The 1st colour index (usually Pink RGB 255,0,255, but can be any colour) is the colour that gives total transparency, and it graduates along the first 16 colour indexes until reaching Blue 46,2,155, which is fully opaque.  The colour you have used on the corresponding area  of the TEX will show through as the transparent colour.

If the 3dz element is a type 6 (which allows transparency information), you can paint the corresponding area of the TRA with the transparency colours you require.  Type 5 elements will not respond to any transparency info that you paint in.  Generally though, you will only have to worry about this unless you are doing a major change to the location of the windows/transparent areas. 

This transparency information also occurs on the P****VTR.pcx file, which is the transparency for the cockpit P****V.pcx textures .

When you have all the necessary PCX files made up and saved in your folder, just double click the PCXtoTPC batchfile, and Voila!!  Select the new .tpc files, chuck them in your EAW folder and you are ready to test things out in game to see how they look!
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It will usually take quite a few attempts to get everything looking the way you want it.  Do some test flights and take some screenies of any problem areas, so that you have references for what needs fixing later on.   Remember to do some ground starts so you can see what the landing gear looks like, and also the shadow.  With a little luck, you will soon have a classy looking skin to fly, and the layered templates all made up ready to crank out a heap more! 

Packaging your skin for other EAW users.

As the only skin manager program that it still currently supported is OAW, and the majority of EAW users run OAW, it makes sense to package your new skin in a zip file so that it is “OAW ready”.  Your choice of course, but it’s quite easy.  First look at the Skins section of OAW to determine which A-** folder your skin should go in.  For this example the B-17 uses folders with the prefix “A-06”.  It also makes sense to name your skins in a logical way, so that particular skins are easy to find.  Immediately after the A-xx prefix I put “HR” if required, then a “G” to indicate the model, the next bit indicates the unit the aircraft fought with, and finally finish off with the aircraft’s name.  So the final folder name for the above skin might be “A-06 HR G 381stBG Dreambaby”.  Using this sort of system, all HR aircraft are grouped together, all B-17G’s are grouped together, and all aircraft of a particular unit are also grouped together.  

In your skinning folder, create a new folder and call it “Skinfolder”, and inside this folder create another folder with the name you just decided on.  If you want to include any other files such as .flt, mainscreens, batchfiles, pcx files or other optional extras, create a separate folder for them here as well.  Take all your new 3dz and tpc files and drop them into the A-** folder you just created.  In this folder you must also put a small .jpg screenie of your aircraft (about 400x300 is plenty big enough), and a contents.txt file.  This is the same as the readme, and should contain all the details about the skin, it’s pilot, unit, time of action, installation procedure, credits for the skin/model etc. etc.  Likewise, drop all the other files you want in their relevant folders.
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Create and open the new .zip file, go back to your skinning folder, then drag and drop the entire “Skinfolder” you just made, into the zip file.  A screen will come up, make sure the ‘save full path’ option is off, and click ‘Add’.  The zip should now have all the files stored in the correct folders.  The user should be able to unzip it straight into their OAW folder and have it correctly installed.  Test it on your own OAW setup to make sure it works before you send it to Sandbagger!

Other Tutorials and resources.

Take the time to check out as many other skinning tutorials as you can find, as every tutorial has different methods and ideas that you may want to try out.  Here’s some links and quick descriptions.

· Mosi’s – EAW low res, PSP5 - http://mosi.furballcentral.com/ 

· DeanH’s – EAW Hires.  Not sure of it’s availability, but ask Dean and he’ll let you know.

· Mudmover’s – IL2-FB, Bare metal FX,  - http://magnum-pc.netfirms.com/mudmovers/Sims/FB/fb_skinnersguide.htm
· Skinner’s Heaven – IL2-FB, Great resource site & tutorials! - http://www.1java.org/sh/
· Pinoy PSP tutorials – general, not skinning specific - http://www.pinoy7.com/psptutorials/default.htm
· PSP User’s group tutorials – general again - http://www.pspug.org/tut/tutbasic.shtml
· Chompy’s Layer Tutorials 1 and 2 – Add-ons page at http://www.sandbaggeruk.com/chompy.html
· Simmers Paintshop – Forums, markings, fonts – Brilliant! http://www.simmerspaintshop.com/
That’s a good start, but remember that a web search for PSP tutorials should give you a multitude of cool sites and ideas.

Credits

I would like to thank some of EAW’s great skinners who have been kind enough to share with me some tips and techniques that they use, so thanks to Mosi, Salty, and DeanH who have added many tricks to my book!  Every little technique that you can learn is most helpful, not only in getting a better quality product, but also in saving time.  Also thanks do DeanH for the use of his Layer concept illustrations.

Thanks also to YOU, for reading through all the way to here (now that’s staying power!) - I hope that this tutorial has been of some use to you, and good luck with your skinning (
John “Chompy” Masters,

16th February, 2004

jdmasters@ozemail.com.au
